Sélection du véhicule

ENGINE SCOPE: CREATION, SELECTION D'UN VEHICULE

Dans la fenêtre principale, cliquez sur le bouton 'Select vehicle'. Une nouvelle fenêtre est affichée

Pour ajouter un nouveau véhicule, cliquer sur le bouton 'New'
Saisissez le nom du véhicule saisi et son nombre de rapports de boîte.
Lorsque un ou plusieurs noms de véhicule existent, cliquer sur le nom de ce véhicule dans la liste 'Vehicles'.
Une fois la sélection du véhicule effectuée, sélectionner le rapport dans la liste 'Gear' puis cliquer sur le bouton 'OK'. Pour quitter sans changer la sélection initiale du véhicule, cliquer sur le bouton 'Cancel'.

Lorsque le véhicule a été sélectionné toutes les fonctions de la fenêtre principale sont activées.

Voir aussi:

  • Etalonnage de la vitesse de rotation du moteur
  • Etalonnage de la vitesse du véhicule

Retour au sommaire


a propos de

ENGINE SCOPE: A PROPOS DU LOGICIEL

Bien qu'un soin tout particulier ait été pris pour l'analyse la programmation et les tests de ce logiciel, des défauts peuvent subsister ayant pour conséquence un dysfonctionnement partiel ou total. L'auteur du logiciel ne saurait être tenu responsable des désagréments et des conséquences causés par ces dysfonctionnements. Il appartient à l'utilisateur final de procéder, selon ses besoin, à une validation appropriée du logiciel.

Le logiciel EngineScope n'est pas un gratuiciel. La protection des droits d'auteurs s'applique au logiciel EngineScope. Toute utilisation illicite expose les fraudeurs aux sanctions prévues par la loi. L'utilisation du logiciel EngineScope est protégé par un code d'accès. Ce code d'accès est permanent pour une version donnée et pour un ordinateur donné (La version est affichée au lancement du programme). Lors du premier lancement de l'application, noter le code qui apparait dans la fenêtre 'Registration Key for Computer Id' (format xxxx-xxxx-xxxx-xxxx). Communiquer ce code d'identification via le courriel indiqué sur le site depuis lequel l'application a été téléchargée.

Une fois le code obtenu, lancer à nouveau l'application et saisir ce code; ceci même si le code d'identification de votre ordinateur est différent de celui qui avait été relevé. Le logiciel est alors prêt à fonctionner. En cas d'échec, l'application démarre, mais aucune fonction n'est active.

Nota: Le code d'enregistrement est unique et ne peut être transféré.


Acquisition de données

ENGINE SCOPE: ACQUISITION DE DONNEES

Dans la fenêtre principale, cliquez sur le bouton 'Acquire run'. Une nouvelle fenêtre est affichée.

Sélectionner le rapport à l'aide des flèches montantes et descendantes dans le champ 'Gear'. Pour activer les compteurs (sans affichage ni enregistrement de la courbe de vitesse), cliquer sur le bouton 'Dials on', pour les désactiver, cliquer sur le bouton 'Dials Off'

Pour effectuer une mesure cliquer sur le bouton 'Start', pour l'arrêter, cliquer sur le bouton 'Stop'. Pendant la durée de la mesure, la distance (exprimée en mètres dans le champ 'Distance') , le temps écoulé (exprimé en secondes dans le champ 'Elapsed time'), la vitesse instantanée (exprimée en km/h et m/s dans le champ 'Speed'), la vitesse de rotation du moteur (exprimée en tr/min dans le champ 'Revs') sont affichées, ainsi que le profil de vitesse. Pendant l'acquisition de données, le témoin lumineux ne clignote pas.

Nota: Il est possible de déclencher le départ et l'arrêt de l'acquisition à l'aide de la séquence de clés 'Ctrl + s'

Profil de vitesse

La section 'Speed' contient un afficheur graphique dans lequel le profil les vitesses lues par l'interface et converties par le logiciel est affiché en mode continu. L'échelle de présentation de ce profil est automatique lorsque les champs 'Time scale' et 'Speed scale' contiennent les valeurs '10' et '0'. Il est possible de forcer les échelles en saisissant des valeurs appropriées. Cliquer sur la case 'Record data' pour enregistrer les données numériques des fréquences dans un fichier de données. Un double click sur le profil de vitesse provoque l'affichage du même profil dans une fenêtre de tracé formaté. Ce profil est statique.

Compteurs

La fenêtre comprend en outre trois compteurs: un compte-tours, un tachymètre et un accéléromètre. La fréquence de rafraichissement de l'affichage de ces compteurs est liée au 'Dwell time' fixé dans la fenêtre 'Interface control'.

Une fois l'acquisition de données effectuée, cliquer sur le bouton 'Return'. Le témoin lumineux de l'interface clignote à nouveau à une fréquence proportionnelle à celle de la rotation du moteur.


Analyse de données

ENGINE SCOPE: ANALYSE DES DONNEES

Les données peuvent être traitées à l'aide des fonctions contenues dans la fenêtre 'Data analysis' du logiciel EngineScope. Dans la fenêtre principale, cliquez sur le bouton 'Analyze run'. Une nouvelle fenêtre est affichée.

Sélectionner un répertoire contenant des fichiers de données en saisissant le chemin complet dans le champ 'Data directory' ou en cliquant sur le '?' afin d'utiliser le navigateur. Par défaut, les fichiers de données sont enregistrés dans le répertoire 'c:\HTH\EngineScope\Data'. La liste des fichiers disponibles est affichée dans la liste déroulante 'Data file names'. Sélectionner l'un ou l'autre des fichiers de la liste pour afficher ses informations générales.

Sélectionner le type de tracé souhaité dans la liste 'Plot types'. Le tracé sélectionné est affiché sous forme de tracé formaté. Liste des tracés disponibles

  • Fréquence moteur: exprimée en Hertz en fonction du temps exprimé en secondes
  • Régime moteur: exprimé en tours par minute en fonction du temps exprimé en secondes
  • Distance: exprimée en mètres en fonction du temps exprimé en secondes
  • Vitesse: exprimée en mètres par seconde en fonction du temps exprimé en secondes
  • Vitesse: exprimée en kilomètres par heure en fonction du temps exprimé en secondes
  • Accélération: exprimée en mètres par seconde carré en fonction du temps exprimé en secondes
  • Accélération: exprimée en g en fonction du temps exprimé en secondes

Trois fonctions mathématiques peuvent être appliquées aux données brutes, selon que leurs cases resopectives sont cochées ou non. Ces fonctions sont appliquées dans l'ordre où elles apparaissent à l'écran: Lissage ('Smooth') puis ré-échantillonnage ('Resample') et enfin troncature ('Trim')

  • Smooth: Le lissage permet l'amélioration de la représentation des courbes, l'effet est proportionnel à la longueur du filtre ('Filter length')
  • Resample: Le ré-échantillonnage permet la comparaison de courbes acquises dans des conditions de Dwell time différentes. Le pas est fixé par le paramètre 'Step size' et le seuil de déclenchement du ré-échantillonnage est fixé par le paramètre 'Trigger level'
  • Trim: La troncature permet de le conserver que les données comprises entre les temps fixés dans 'Lower bound' et 'Upper bound'

Export

Les données peuvent aussi être analysées au moyen de tableurs ou de logiciels spécialisés afin de procéder à des calculs complémentaires destinés à évaluer la puissance et le couple du véhicule. Cliquer sur le bouton 'Export' et le type de données sélectionnées sera copié dans le Presse-papier de Windows; ces données sont alors disponible pour être collées dans toute application compatible, dans Excel par exemple:

Voir aussi:

  • Format des fichiers de données


Format des fichiers de données

ENGINE SCOPE: FORMAT DES FICHIERS DE DONNEES

Chaque cycle d'acquisition de données est enregistré dans une fichier texte situé dans le répertoire c:\EngineScope\Data\. Le nom du fichier est composé de l'année (4 chiffres), du mois (2 chiffres), du jour (2 chiffres), de l'heure (2 chiffres), de la minute (2 chiffres) et de la seconde (2 chiffres) de déclenchement de l'acquisition; cette série de chiffres est suivie d'un suffixe '_run', '_diag', '_cal' qui différencie des données acquises.
Chaque fichier est composé d'une entête (inscrite entre les caractères de commentaires du langage C /* et */), suivie de lignes contenant les mesures.

Mesures

A chaque mesure correspond une ligne. La première valeur est le temps écoulé depuis le début de l'acquisition (exprimé en secondes), la seconde valeur est la vitesse exprimée en m/s. Ces deux valeurs sont séparées par le signe 'Tabulation'.

Les données peuvent être traitées à l'aide des fonctions contenues dans la fenêtre 'Data analysis' du logiciel EngineScope. Elles peuvent aussi être analysées au moyen de tableurs ou de logiciels spécialisés afin de procéder à des calculs complémentaires destinés à évaluer la puissance et le couple du véhicule.

Voir aussi:

  • Analyse des données


Tracés formatés

ENGINE SCOPE: TRACE FORMATE

Il est possible d'afficher le contenu de n'importe quel profil dynamique dans une fenêtre permettant le paramétrage complet de l'affichage du tracé ainsi que son export dans différents formats (numériques et graphiques). Cette fenêtre est aussi utilisée pour l'affichage des données traitées à l'aide des fonctions contenues dans la fenêtre 'Data analysis'.

Fonctions de base disponibles dans la fenêtre de tracé formaté:

  • Effectuer un click and drag pour agrandir n'importe quelle zone du tracé; faire un simple click sans bouger la souris pour afficher le signal complet.
  • Maintenir le bouton 'Ctrl' tout en déplaçant la souris pour afficher un curseur qui suit automatiquement le signal et affiche en bas de la fenêtre le canal, l'index de l'enregistrement pointé ainsi que ses valeurs d'abscisses et d'ordonnées.
  • Sélectionner le menu 'Files | Save as...' pour enregistrer le tracé dans un format numérique (extension .txt) ou graphique (extensions .wmf, .emf, .bmp, .jpg)
  • Sélectionner le menu 'Parameters...' pour afficher la fenêtre contenant toutes les variables permettant la mise en forme du tracé (échelles, choix des couleurs, du format des traits, des symboles, etc.)


ENGINE SCOPE

Le logiciel EngineScope mesure, enregistre et affiche les performances de tous types de véhicules motorisés. Il nécessite une interface électronique installée entre le moteur du véhicule testé et le PC sur lequel est exécutée l'application. Le logiciel nécessite un code d'enregistrement pour fonctionner.

Le processus d'utilisation du logiciel est le suivant:
  • Branchement de l'interface
  • Lancement de l'application
  • Création, sélection d'un véhicule
  • Etalonnage de la vitesse de rotation du moteur
  • Etalonnage de la vitesse du véhicule
  • Acquisition de données
  • Analyse des données
Une fonction complémentaire permet de le contrôle de l'interface de manière à optimiser son fonctionnement ou à effectuer des diagnostics.


Interface

ENGINE SCOPE: BRANCHEMENT DE L'INTERFACE

Débrancher le connecteur du capteur de rotation du vilebrequin et insérer le connecteur de l'interface.

Brancher le câble USB sur le PC. Le témoin lumineux de l'interface clignote rapidement 5 fois puis s'éteint. L'interface est prête à fonctionner. Si le moteur tourne et que l'interface est correctement branchée, le témoin lumineux clignote à une fréquence proportionnelle à celle de la rotation du moteur. Si ces deux conditions ne sont pas remplies (ou lorsque le système est en acquisition de données), le témoin lumineux reste éteint.

Nota: le signal du capteur est prélevé différemment selon que le capteur est de type "effet Hall" ou "inductif". Les capteurs de type "effet Hall" sont installés sur les motorisations X20XEV. Le signal est lu entre les bornes 3 (Masse) et 2 (Signal rectangulaire 0-15 V à rapport cyclique variable). Les capteurs "inductifs" sont présents sur toutes les autres motorisations. Le signal est lu entre les bornes 3 (Masse) et 1 (Signal sinusoïdal de fréquence et tension variables).

Voir aussi:

  • Contrôle de l'interface
  • Lancement de l'application
  • Mise à jour du microcode


Contrôle de l'interface

ENGINE SCOPE: CONTROLE DE L'INTERFACE

La fenêtre 'Interface Control' contient des fonction destinées à aider à poser un diagnostic en cas de défaut de fonctionnement ou à optimiser le du système. La liste des ports de communication est affichée dans la liste 'Comm. Ports'. Cliquer sur le nom du port série auquel est attaché l'interface. Cliquer sur le bouton 'Reset Interf.' pour réinitialiser l'interface. Une salve de cinq clignotements rapides indique que l'interface a été correctement réinitialisée. A l'issue de cette réinitialisation, un message indique les informations de compatibilité: code de l'application et version du microcode tels qu'attendus et tels qu'ils ont été lus à partir de l'interface.

Cliquer sur le bouton 'Dwell time' pour afficher la durée pendant laquelle les mesures de fréquence sont effectuées par l'interface. Cette durée est programmable entre 1 et 1000 ms, pas pas de 1 ms. La valeur par défaut est de 200 ms.

Lorsqu'une acquisition test est lancée, le temps de cycle réel est affiché (champ 'Sampling time', exprimé en ms) ainsi que la fréquence lue par l'interface (champ 'Frequency', exprimé en Hertz, et profil de fréquences) et le temps écoulé (champ 'Run time', exprimé en secondes). Pour effectuer une mesure, cliquer sur le bouton 'Start', pour l'arrêter, cliquer sur le bouton 'Stop'.

Nota: Il est possible de déclencher le départ et l'arrêt de l'acquisition à l'aide de la séquence de clés 'Ctrl + s'

Profil de fréquences

La section 'Frequency' contient un afficheur graphique dans lequel le profil des fréquences lues par l'interface est affiché en mode continu. L'échelle de présentation de ce profil est automatique lorsque les champs 'Time scale' et 'Freq. scale' contiennent les valeurs '10' et '0'. Il est possible de forcer les échelles en saisissant des valeurs appropriées. Cocher la case 'Record data' pour enregistrer les données numériques des fréquences dans un fichier de données. Un double click sur le profil des fréquences provoque l'affichage du même profil dans une fenêtre de tracé formaté. Ce profil est statique.

Voir aussi:

  • Interface
  • Mise à jour du microcode


Lancement de l'application

ENGINE SCOPE: LANCEMENT DE L'APPLICATION

Une fois l'interface branchée et alimentée, lancer l'application EngineScope. L'application se charge de trouver automatiquement l'interface.

Le message 'Interface found at COMx' indique que l'interface a été trouvée et qu'elle est compatible avec la version du logiciel.

Nota: Cette recherche peut prendre plusieurs secondes.

En cas d'échec, le message d'erreur 'No interface found. Please check interface and cables.' est affiché. La fenêtre principale de l'application apparait, mais les boutons de contrôle des fonctions d'acquisition sont désactivés.

Nota: Au cas où plusieurs interfaces seraient branchées au même PC, il est possible de choisir une interface spécifique dans la fenêtre de Contrôle de l'interface.

Lorsque le code d'enregistrement est correct, la fenêtre principale est affichée

Voir aussi:

  • Sélection d'un véhicule
  • Contrôle de l'interface


Etalonnage compte tours

ENGINE SCOPE: ETALONNAGE DE LA VITESSE DE ROTATION DU MOTEUR

Un étalonnage de la vitesse de rotation du moteur doit être effectué pour chaque véhicule testé. Cet étalonnage peut être réalisé grâce au compte tour utilisé comme mesure de référence, ou directement à partir du nombre de dents que comporte la roue codeuse solidaire du vilebrequin.

Méthode directe

Cliquer sur le bouton 'PPR' (Pulses Per Round) et saisir le nombre d'impulsions produites à chaque tour de vilebrequin. Aucune acquisition de signal n'est nécessaire. Sauf exception, la roue codeuse comporte 58 dents (60 dents, moins 2 dents qui indiquent une rotation complète).

Méthode utilisant un compte tours

Saisir le nombre de tour minutes cible dans le champ 'Ref. Revs'. Lancer le moteur et stabiliser de rotation à une vitesse aussi proche que possible de la valeur cible. Cliquer sur le bouton 'Start'. Pendant la durée de la mesure, le temps (exprimé en secondes dans le champs 'Elapsed time') est affiché, ainsi que le profil de vitesse; le témoin lumineux ne clignote pas.

Nota: Il est possible de déclencher le départ et l'arrêt de l'acquisition à l'aide de la séquence de clés 'Ctrl + s'

Profil de vitesse

La section 'Revs' contient un afficheur graphique dans lequel le profil de la vitesse de rotation du moteur lue par l'interface et convertie par le logiciel est affiché en mode continu. L'échelle de présentation de ce profil est automatique lorsque les champs 'Time scale' et 'Revs. scale' contiennent les valeurs '10' et '0'. Il est possible de forcer les échelles en saisissant des valeurs appropriées. Cliquer sur la case 'Record data' pour enregistrer les données numériques des fréquences dans un fichier de données. Un double click sur le profil de vitesse provoque l'affichage du même profil dans une fenêtre de tracé formaté. Ce profil est statique.

Sauvegarde de la valeur d'étalonnage

Dans les deux cas (Méthode directe et Méthode utilisant un compte tours), le logiciel demande confirmation de la conservation de la valeur d'étalonnage, ou de son remplacement si un étalonnage avait été précédemment effectué.


Etalonnage vitesse

ENGINE SCOPE: ETALONNAGE DE LA VITESSE DU VEHICULE

Pour chaque véhicule sélectionné, un étalonnage doit être effectué pour chaque rapport utilisé pour effectuer les tests de performance. Ces étalonnages restent valables tant que les caractéristiques du véhicule restent inchangées (ex. changement de type de pneumatiques).

Dans la fenêtre principale, cliquez sur le bouton 'Calibration'. Une nouvelle fenêtre est affichée.

Dans la mesure du possible effectuer l'étalonnage dans une portion droite. Saisir la distance sur laquelle l'étalonnage sera effectué, par exemple un kilomètre (1000 m), si les repères de distance sont des bornes kilométriques.

Nota: Plus la distance est longue meilleure est la qualité de l'étalonnage

Sélectionner le rapport à l'aide des flèches montantes et descendantes dans le champ 'Gear'. Engager le rapport prévu. Au franchissement du repère de distance, cliquer sur le bouton 'Start'. Roulez à vitesse quasi constante sans changer de rapport. La courbe de vitesse est affichée pendant la durée de l'étalonnage, ainsi que la valeur du temps écoulé (exprimé en secondes dans le champ 'Elapsed time') depuis le passage du repère de distance; le témoin lumineux ne clignote pas.

Nota: Il est possible de déclencher le départ et l'arrêt de l'acquisition à l'aide de la séquence de clés 'Ctrl + s'

Une fois les données acquises, il est possible d'afficher le tracé formaté en double-cliquant sur le tracé de vitesse. La vitesse moyenne est affichée (en m/s et en km/h dans les champs 'Average speed').

Nota: Les variations de vitesse n'ont pas d'effet sur le calcul de l'étalonnage. Au franchissement du repère de distance de fin de parcours d'étalonnage, cliquer sur le bouton 'Stop'.

Profil de vitesse

La section 'Speed' contient un afficheur graphique dans lequel le profil les vitesses lues par l'interface et converties par le logiciel est affiché en mode continu. L'échelle de présentation de ce profil est automatique lorsque les champs 'Time scale' et 'Speed scale' contiennent les valeurs '10' et '0'. Il est possible de forcer les échelles en saisissant des valeurs appropriées. Cliquer sur la case 'Record data' pour enregistrer les données numériques des fréquences dans un fichier de données. Un double click sur le profil de vitesse provoque l'affichage du même profil dans une fenêtre de tracé formaté. Ce profil est statique.

Sauvegarde de la valeur d'étalonnage

A l'issue de l'acquisition de données, le logiciel demande confirmation de la conservation de la valeur d'étalonnage, ou de son remplacement si un étalonnage avait été précédemment effectué.


Sélection du véhicule

ENGINE SCOPE: MISE A JOUR DU MICRO-CODE

L'interface contient un microprocesseur dans lequel un logiciel est exécuté. Ce logiciel, le microcode, peut être amené à évoluer. Appliquer la procédure suivante pour procéder à sa mise à jour.

  • Débrancher l'interface du port USB,
  • Télécharger la nouvelle version du microcode (fichier caractérisé par l'extension .pde)
  • Installer l'interface de développement (IDE) Arduino (http://www.arduino.cc/en/Main/Software) (Gratuiciel)
  • Ouvrir le fichier contenant la nouvelle version du microcode
  • Compiler le microcode
  • Brancher l'interface du port USB, et dès que les 5 clignotements sont apparus, uploader le microcode.

Test avancé

Nota: Utilisateurs confirmés seulement, sans aucun risque pour l'interface.

Il est possible de tester l'interface à l'aide d'un terminal de communication (Utiliser l'hyperTerminal de Windows; ou l'un des très nombreux logiciels disponibles en version gratuite). Les paramètres de communication sont 115200 Baud, 8 bits, 1 bits d'arrêt, pas de contrôle de flux. Ouvrir une connexion et saisir '3!00'. L'interface doit répondre '00'. Les caractères '00' peuvent être remplacés par n'importe quel paire de caractères (ex. '3!##'). Si l'interface ne répond pas ou que qu'elle retourne des caractères différents de ceux qui ont été envoyés, rechercher un éventuel problème de connexion de l'interface; en dernier recours, recharger le microcode.

Voir aussi:

  • Contrôle de l'interface